If your Newscoop server is hosted by Sourcefabric, installation will be taken care of by the Newscoop team, and so you do not need to read the following chapters.
If you are upgrading a previous installation of Newscoop on your own server, please read the chapter Backup and upgrade before you begin.
Newscoop can be installed on any standard GNU/Linux distribution which can provide the Apache web server and PHP 5.3 or later. These distributions include Debian 8.0 (Jessie), Ubuntu 14.04 LTS (Trusty), and Red Hat Enterprise 7.1 (Maipo). Installation instructions for these supported distributions are in the following chapters.
A MySQL server must be available for Newscoop to use, although this need not be installed on the same server as Newscoop itself. See the chapter MySQL installation for details.
Installation of a mail server, such as Postfix, is optional, because Newscoop can be configured to send notification emails via a remote SMTP server. This setting is mentioned in the chapter System preferences.
After Newscoop is installed for the first time, a browser wizard enables you to set database connection parameters and the default administrator password. This wizard is covered in the chapter Installation steps.
- PHP version must be at least 5.3.3 (5.5.9-1ubuntu4.11 installed)
- PHP version must not be 5.3.16 as Symfony won't work properly with it
- Vendor libraries must be installed
- cache/ directory must be writable
- log/ directory must be writable
- conf/ directory must be writable
- library/Proxy/ directory must be writable
- themes/ directory must be writable
- plugins/ directory must be writable
- public/ directory must be writable
- images/ directory must be writable
- date.timezone setting must be set
- Configured default timezone "Europe/Berlin" must be supported by your installation of PHP
- json_encode() must be available
- session_start() must be available
- ctype_alpha() must be available
- token_get_all() must be available
- simplexml_import_dom() must be available
- detect_unicode must be disabled in php.ini
- PCRE extension must be available
- sendmail should be installed
- You should use at least PHP 5.3.4 due to PHP bug #52083 in earlier versions
- When using annotations you should have at least PHP 5.3.8 due to PHP bug #55156
- You should not use PHP 5.4.0 due to the PHP bug #61453
- You should use PHP 5.3.18+ or PHP 5.4.8+ to always get nice error messages for fatal errors in the development environment due to PHP bug #61767/#60909
- PCRE extension should be at least version 8.0 (8.31 installed)
- PHP-XML module should be installed
- mb_strlen() should be available
- iconv() should be available
- utf8_decode() should be available
- posix_isatty() should be available
- intl extension should be available
- intl extension should be correctly configured
- intl ICU version should be at least 4+
- a PHP accelerator should be installed
- short_open_tag should be disabled in php.ini
- magic_quotes_gpc should be disabled in php.ini
- register_globals should be disabled in php.ini
- session.auto_start should be disabled in php.ini
- PDO should be installed
- PDO should have some drivers installed (currently available: mysql)